summaryrefslogtreecommitdiff
path: root/gitpython/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gitpython/PKGBUILD')
-rw-r--r--gitpython/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/gitpython/PKGBUILD b/gitpython/PKGBUILD
new file mode 100644
index 0000000..a4b9d56
--- /dev/null
+++ b/gitpython/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Jon Bergli Heier <snakebite@jvnv.net>
+pkgname=gitpython
+pkgver=0.3.0_beta2
+_pkgver=0.3.0-beta2
+pkgrel=1
+pkgdesc="A python library used to interact with Git repositories"
+arch=(i686 x86_64)
+url="http://gitorious.org/git-python"
+license=('BSD')
+depends=('git' 'python-gitdb')
+makedepends=('git')
+conflicts=('gitpython-git')
+source=("http://pypi.python.org/packages/source/G/GitPython/GitPython-${_pkgver}.tar.gz")
+md5sums=('88acb9fa2d61e4ca25664619fca0eda3')
+
+build() {
+ cd "$srcdir/GitPython-$_pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 || return 1
+ install -D -m 644 LICENSE "$pkgdir"/usr/share/licenses/gitpython/LICENSE
+}
+# vim:set ts=2 sw=2 et: