summaryrefslogtreecommitdiff
path: root/libtorrent-ipv6/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libtorrent-ipv6/PKGBUILD')
-rw-r--r--libtorrent-ipv6/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/libtorrent-ipv6/PKGBUILD b/libtorrent-ipv6/PKGBUILD
new file mode 100644
index 0000000..1cfaf0b
--- /dev/null
+++ b/libtorrent-ipv6/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jon Bergli Heier <snakebite@jvnv.net>
+# Based on the official PKGBUILD
+
+pkgname=libtorrent-ipv6
+pkgver=0.12.6
+pkgrel=1
+pkgdesc="BitTorrent library written in C++"
+arch=('i686' 'x86_64')
+url="http://libtorrent.rakshasa.no"
+license=('GPL')
+depends=('libsigc++2.0' 'openssl')
+options=('!libtool')
+provides=('libtorrent=0.12.6')
+source=(http://libtorrent.rakshasa.no/downloads/libtorrent-$pkgver.tar.gz
+http://home.samfundet.no/~sesse/libtorrent-0.12.6-ipv6-06.patch)
+md5sums=('037499ed708aaf72988cee60e5a8d96b'
+'a1e2cd1fc64ff04f14eb1bcdfd2af19b')
+
+build() {
+ cd "$srcdir/libtorrent-$pkgver"
+
+ patch -p1 < $srcdir/libtorrent-0.12.6-ipv6-06.patch
+
+ CXXFLAGS="$CXXFLAGS -fno-strict-aliasing" \
+ ./configure --prefix=/usr --disable-debug --enable-ipv6 || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: