summaryrefslogtreecommitdiff
path: root/rtorrent-ipv6/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'rtorrent-ipv6/PKGBUILD')
-rw-r--r--rtorrent-ipv6/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/rtorrent-ipv6/PKGBUILD b/rtorrent-ipv6/PKGBUILD
new file mode 100644
index 0000000..239cc1f
--- /dev/null
+++ b/rtorrent-ipv6/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jon Bergli Heier <snakebite@jvnv.net>
+# Based on the official PKGBUILD
+
+pkgname=rtorrent-ipv6
+pkgver=0.8.6
+pkgrel=1
+pkgdesc="Ncurses BitTorrent client based on libTorrent"
+arch=('i686' 'x86_64')
+url="http://libtorrent.rakshasa.no"
+license=('GPL')
+depends=('libtorrent=0.12.6' 'curl>=7.14.3' 'xmlrpc-c>=1858')
+provides=('rtorrent')
+source=(http://libtorrent.rakshasa.no/downloads/rtorrent-$pkgver.tar.gz
+http://home.samfundet.no/~sesse/rtorrent-0.8.6-ipv6-06.patch)
+md5sums=('b804c45c01c40312926bcea6b55bb084'
+'7c56334795ab69c6b8af35650c2600ff')
+
+build() {
+ cd "$srcdir/rtorrent-$pkgver"
+
+ patch -p1 < rtorrent-0.8.6-ipv6-06.patch
+
+ CXXFLAGS="$CXXFLAGS -fno-strict-aliasing" \
+ ./configure --prefix=/usr --disable-debug --with-xmlrpc-c --enable-ipv6 || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+
+# vim:set ts=2 sw=2 et: