summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Bergli Heier <jonheier@start.no>2007-10-01 00:04:47 +0200
committerJon Bergli Heier <jonheier@start.no>2007-10-01 00:04:47 +0200
commitc062ac07e6241cf32a4a5655775aa037bdb1e76e (patch)
treea3b41bfc3ea1b57af6b95e4072ce7fcbbdaa4afb /setup.py
parent2b47e8d3c263bdaff9d48f3a1a480631b22ee145 (diff)
Moved pykfx.py to pykfx/__init__.py
Added self.names in Styles along with int support in __getitem__. Added setup.py. Added fscalc, an extension that calculates text sizes for a given font. Using boost.python-wrapper for fscalc.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c131572
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,17 @@
+import subprocess, re
+from distutils.core import setup, Extension
+
+freetype_config = subprocess.Popen('freetype-config --cflags --libs', shell = True, stdout = subprocess.PIPE).stdout.read()
+
+setup(
+ name = 'pykfx',
+ version = '0.1',
+ description = 'pykfx is a collection of classes for parsing ASS-scripts.',
+ author = 'Jon Bergli Heier',
+ author_email = 'jonheier@start.no',
+ packages = ['pykfx'],
+ ext_modules = [Extension('pykfx.fscalc', ['fscalc.cpp', 'wrapper.cpp'],
+ include_dirs = re.findall('-I[^\/\w]*([\w\/]+)', freetype_config),
+ libraries = ['boost_python', 'fontconfig'] + re.findall('-l\W*(\w+)', freetype_config),
+ )],
+)